Bodenseematze
2022-01-24T07:50:51Z
Hello together,

I have problems with the keyboard inside my virtual machines.
It seems that all key kombinations with "alt gr" (right alt key) are not working.
That is very annoying because here in Germany a lot of special keys are only reachable via the Alt Gr key (e.g. the backslash, the @ and others).

Is it possible that the reason for this ist that all system key shortcuts for RDTab include the right alt key?

Am I the only one with that problem?
Timothy
  • Timothy
  • 100% (Exalted)
  • Flock Leader
2022-01-26T20:26:52Z
Originally Posted by: Bodenseematze 

Hello together,

I have problems with the keyboard inside my virtual machines.
It seems that all key kombinations with "alt gr" (right alt key) are not working.
That is very annoying because here in Germany a lot of special keys are only reachable via the Alt Gr key (e.g. the backslash, the @ and others).

Is it possible that the reason for this ist that all system key shortcuts for RDTab include the right alt key?

Am I the only one with that problem?



Correct, that is why you are having issues. SysKey initiator key (or first key) will override the typable characters since it's an escape key. Change it to something else, like Right-Ctrl, or just disable SysKey entirely.

image.png
IslandInsight
2024-07-06T19:08:54Z
Hello,

You're definitely not alone in experiencing this issue! The "Alt Gr" key often causes problems in virtual machines due to how keyboard inputs are managed. It’s possible that RDTab or similar tools might be intercepting those key combinations.

A workaround might be to remap your keys or adjust the settings in your virtual machine software to pass through the "Alt Gr" key correctly. You could also try using an on-screen keyboard within the VM for those specific characters.

Hope this helps!
IslandInsight
2024-07-08T19:13:13Z
Hi there,

You're definitely not alone in facing this issue. The Alt Gr key not working in virtual machines can indeed be quite frustrating, especially with German keyboards. It’s possible that system key shortcuts for RDTab involving the right alt key might be causing the conflict.

Have you tried remapping the keys or using a different virtual machine software to see if the issue persists? Sometimes, updating the VM tools or drivers can also resolve such problems.

Hope this helps!
full film